2015年11月4日水曜日

レンタル サーバーを dual boot (debian + openbsd) にする



5)レンタル サーバーを dual boot(debian + openbsd)にする。

20GB分だけ まずdebianをいれます。

debian を起動し / に bsd.rd を保存します。
また fdisk で openbsd areaを確保ておきます。


/boot/grub/grub.cfg の
menuentry 'Debian GNU/Linux, with Linux 3.2.0-4-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu
 --class os {
    load_video
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set=root 48513cc3-0824-41d2-b0e2-33cefa6dfbc7
    echo    'Loading Linux 3.2.0-4-amd64 ...'
    linux    /boot/vmlinuz-3.2.0-4-amd64 root=UUID=48513cc3-0824-41d2-b0e2-33cefa6dfbc7 ro single  
    echo    'Loading initial ramdisk ...'
    initrd    /boot/initrd.img-3.2.0-4-amd64
}
部分を



menuentry 'Debian GNU/Linux, with Linux 3.2.0-4-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu
 --class os {
    load_video
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set=root 48513cc3-0824-41d2-b0e2-33cefa6dfbc7
    echo    'Loading Linux 3.2.0-4-amd64 ...'
    kopenbsd /bsd.rd
    echo    'Loading initial ramdisk ...'
    boot
}

と書き換え この 'Debian GNU/Linux, with Linux 3.2.0-4-amd64 (recovery mode)'メ ニューで起動すると OPENBSDインストーラが動きます。 http での sd1へ の インストールとなります。 

その後もう一度 debian で立ち上げ

 cat /etc/grub.d/40_custom を
ーーーーーーーーーーーーー
#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "OpenBSD" {
    set root=(hd0,4)
    chainloader +1
}

としてから update-grub するだけです。




ARCH linuxの最終の /boot/grub/grub.cfg は

menuentry 'Arch Linux, with Linux core repo kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-true-ad4103fa-d940-47ca-8506-301d8071d467' {
    load_video
    set gfxpayload=keep
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos2'
    linux    /boot/vmlinuz-linux root=/dev/sdb2 rw  quiet

    initrd    /boot/initramfs-linux.img
}

menuentry 'openbsd' {
set  root='hd0,msdos1'
chainloader +1
}

menuentry 'INSTALL openbsd' {
kopenbsd /bsd.rd-57
boot
}








番外編) このサーバーは レン タルサーバーで動いてます。
お名前.comで メモリ1G HDD100GBです。

load averages:  0.07,  0.08,  0.12                                           aoiyuma.mydns.jp 15:16:43
46 processes: 45 idle, 1 on processor
CPU0 states:  0.0% user,  0.0% nice,  0.2% system,  0.0% interrupt, 99.8% idle
CPU1 states:  0.0% user,  0.0% nice,  0.0% system,  0.0% interrupt,  100% idle

Memory: Real: 271M/551M act/tot Free: 435M Cache: 197M Swap: 0K/2055M
  PID USERNAME PRI NICE  SIZE   RES STATE     WAIT      TIME    CPU COMMAND
 2817 _snort     4    0  502M  244M sleep     bpf       0:33  0.00% snort
 5383 root       2    0 1028K 1504K idle      select    0:21  0.00% sshd
24488 _syslogd   2    0 1120K 1484K idle      kqread    0:19  0.00% syslogd
 6203 tuyosi     2    0 3880K 2756K sleep     select    0:11  0.00% sshd
    1 root      10    0  524K  540K idle      wait      0:04  0.00% init
20705 _pflogd    4    0  684K  392K sleep     bpf       0:03  0.00% pflogd
16968 tuyosi     2    0 1436K 3780K sleep     kqread    0:01  0.00% imap
 3272 tuyosi     2    0 1444K 3848K sleep     kqread    0:01  0.00% imap
14486 _dovenul   2    0  948K 4372K sleep     kqread    0:01  0.00% imap-login

と スワップは2Gありますが、CPUは遊んでるような状態です。



# dmesg | grep wd
wd0 at pciide0 channel 1 drive 0: <QEMU HARDDISK>
wd0: 16-sector PIO, LBA48, 20480MB, 41943040 sectors

wd1 at pciide0 channel 1 drive 1: <QEMU HARDDISK>
wd1: 16-sector PIO, LBA48, 81920MB, 167772160 sectors

とハードディスクは QEMU HARDDISKで 想像するに実HDDではなくて
たぶん 数TBのハードディスクの一部なのでしょう。




# fdisk  wd0  
Disk: wd0       geometry: 2610/255/63 [41943040 Sectors]
Offset: 0       Signature: 0xAA55
            Starting         Ending         LBA Info:
 #: id      C   H   S -      C   H   S [       start:        size ]
-------------------------------------------------------------------------------
 0: 83    261  53  49 -    768  20  20 [     4196352:     8142848 ] Linux files* openbsdからもアクセスするためext2
*1: 83      0  32  33 -    261  53  48 [        2048:     4194304 ] Linux files* 
openbsdからもアクセスするため ext2
 2: 00      0   0   0 -      0   0   0 [           0:           0 ] unused     
 3: A6    768  20  21 -   2610 212  34 [    12339200:    29603840 ] OpenBSD    

と wd0は
4GBの arch (ここからもブート可)
2GBの arch ここに grub.cfgはある。もちろんブート可 /dev/wd0i      4128416   2299984   1618720    59%    /mnt-debian-sda2 と1Gちょっとしかいらない
menuentry 'openbsd install-5.7' {
kopenbsd /bsd.rd-57
}


menuentry 'openbsd install-snap' {
kopenbsd /bsd.rd-snap
}


menuentry 'Arch Linux sda111111' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos1'
        linux    /boot/vmlinuz-linux root=/dev/sda1 rw  quiet
        initrd   /boot/initramfs-linux.img
}
arch linuxは そのイメージを 
sftp -i vps1006-001.key  iu1-00008@sftp1001.myvps.jp
な形で転送して、これが仮想CDとなってお名前でOインストールをします。

arch linuxは そのgrubブートローダーを使うだけですから、スワップもいりませんし GUIもいりません。
だから2GBのHDDへも十分入ります。
そしてこのext2に openbsdの必要最小限をバックアップしてます。
/etc, /var/www, /home/tuyosi/*.bat ですね。
そうして万一のクラッシュに備えてます。
80G openbsd クラッシュ -> 15B openbsd クラッシュ -> arch のブートローダでkopenbsd を利用して再インストのあと/etc, /var/www, /home/tuyosi/*.batを
を書き戻して早い普及をはかる。
15GBのopenbsd   (ここからもブート可)

# fdisk  wd1
Disk: wd1       geometry: 10443/255/63 [167772160 Sectors]
Offset: 0       Signature: 0xAA55
            Starting         Ending         LBA Info:
 #: id      C   H   S -      C   H   S [       start:        size ]
-------------------------------------------------------------------------------
 0: 00      0   0   0 -      0   0   0 [           0:           0 ] unused     
 1: 00      0   0   0 -      0   0   0 [           0:           0 ] unused     
 2: 00      0   0   0 -      0   0   0 [           0:           0 ] unused     
*3: A6      0   1   2 -  10442 254  63 [          64:   167766731 ] OpenBSD  

80GBあって 通常はここから起動している。
今もこの状態。

Filesystem  512-blocks      Used     Avail Capacity  Mounted on
/dev/wd1a    160966480  39509296 113408860    26%    /
と十分な余裕があります。












0 件のコメント:

コメントを投稿